Text when built with fbs in docker ubuntu 16 for dialogs is different

Noticed some issues and restructured my code and trying to do it the fbs way in docker ubuntu16 but also work in later ubuntu but when i build it in ubuntu 16 the dialogs look weird.

checked and confirmed all the same pip packages installed in the docker and the host os and code is identical

Doing a diff of the folders shows some differences. Not sure what exactly i should do to be able to build it in ubuntu 16 and have it look right in both ubuntu 16 and higher OS’s.

https://pastebin.com/jWpPRYQi

The other weird thing is when i build this in ubuntu 16 i have no GL errors when testing it in other virtual machines but when i build it in ubuntu 18 i do. So im really torn cause it seems like either way is going to have issues.

ubuntu18 built deb error when run in another ubuntu 18/20 virtual machine
https://pastebin.com/G2Y7PpK9

same code when built in fbs docker ubuntu16 has no GL errors but has the jacked up formatting as noted above for some dialogs.

Wondering if anyone else has possibly seen or had this issue before?

about dialog:
https://pastebin.com/ieUj4TAd

register dialog:
https://pastebin.com/UaVqMNpU

And i get 0 errors when debugging is turned on when the weird formatting issue happens so not sure how one goes about diagnosing the cause.

using these packages in both docker and host os

PyQt5==5.15.0
PyQt5-sip==12.8.0
PyQt5-stubs==5.14.2.2
PyQtWebEngine==5.15.0
PyQt3D==5.15.0

to get fbs ubuntu vm docker to use newer stuff you have to modify
venv-fbs/lib64/python3.6/site-packages/fbs/_defaults/requirements/ubuntu.txt

The only reason im using newer packages then the old 5.9.2 is cause the qtwebengine widgets are broken when built in docker and have missing context menu items compared to the 5.14/5.15 branches

After testing more I found that even switching to 5.9.2 for ubuntu which is the default with docker the same display issues happen. So it appears to be docker OS issue and not PyQT5 version issue. Seems to be how Ubuntu 16 docker interprets the fonts in the .ui files when loaded from what I can tell so far.

Update:
So what i found to fix this was to expand the size beyond what it looks like. For some reason when compiled with ubuntu16 the dimensions and free space between elements is odd. I resized the stuff way larger then it was and made sure no overlaps of the elements even if invisible and now it looks correct.

example:
before in qt designer
image

After in qt designer:
image

looks normal in both Ubuntu16 and Ubuntu18 after compiled in Ubuntu18
image

weird but in case anyone else encounters this hopefully this helps. :slight_smile: